Scott Watermasysk Husband, Father, Bootstrapper, Developer, Builder, Shipper.

💡 TIL: Locking Versions on Netlify

I ran into an interesting build issue after updating a couple of Ruby gems and NPM modules.

By default, when you create a new site on Netlify your Ruby/Node/etc. versions are locked to recent defaults unless you explicitly specify the versions using .ruby-version, .nvmrc, etc.

I suggest going forward, you always an explicit version. By locking the core dependency versions, you will help ensure if you can build it locally, you will likely be able to build it on the remote servers as well.